Important notice about the release of U-tec App V2 official version

Hi guys, we’re glad to inform you that U-tec App V2 (official version) has been released! Since we have fixed some bugs and optimized the user experience in the new version, we strongly suggest you update it now.

Some users may worry about losing the device and user information after updating, but they will all be synced to the new version.

Download method:

Go to the App Store or Google Play to search“U-tec”, then click “Update” or “Download”.

Introduction and user guide of V2

If you want to know more about U-tec App V2 and what is updated, you can view this article:

And here is the V2 user guide:

Last but not least, thanks for all the valuable suggestions during the Beta test period.

If you encounter any problem with this version, don’t hesitate to tell us in this community(U-tec App - U-tec Community). Thanks again!

1 Like

Now that it’s been released, can we expect a local API for Bluetooth, wifi soon?

Including the ability to read/write more attributes through Z-Wave than is currently possible. Especially for home assistant.

I will be unable to update the firmware till 3/2023. Will everything still work, I have guests arriving with their codes in the app. Please let me know.
Thank you


I am unable to create a new user account in version 2.06 of the iOS app. I can fill-in all required fields but the “Get Code” button under the “Verification Code” section cannot be pressed/clicked (new account cannot be created w/o verification code). I have included a screenshot below. The button in question does not work.

Yes, everything would still work even if you don’t update the firmware.

Hello, thank you for your feedback. Could you please tell me you phone model and os version so that we can troubleshoot this?

We’re not happy with the update. The new app does not work on our admin user device who runs Android on one of the new Samsung phones. The old app disappeared; the new app is available. All locks are gone. When we try to add locks, we just get an error. We logged in with another user (which we don’t want to do), the locks become available but get errors when trying to connect. Really really bad, and unstable, especially considering this is how we lock and unlock our building.

1 Like

The new app is completely terrible. It borked my current setup, and now I can’t add the lock back. Did NO ONE TEST THIS ?

People don’t want a huge hassle, but your company seems to be ill equipped to handle support. I’ve left three messages over two days and no one has deigned to call me back.

You guys get an F for this assignment.


Thanks for your feedback, we will fix this issue as soon as possible. Could you please try to log out and log in to your original account again to confirm if it works?

Thanks for your feedback, we will fix this issue as soon as possible. Could you please try to log out and log in to your original account again to confirm if it works?

The shared device should be under the shared address.

Because of your new software I was forced to completely reset to factory (with the help of the 2nd level support person, although it took me 10 tries to get someone on the phone, Ieft three messages over two days and never got the courtesy of a reply) and re-set up everything.

Ya’ll did not think any of this through. Clearly, testing was minimal at best and no real-world testing with actual humans was performed.

I’m pretty disgusted. Your technology is very good. But lots of companies have good technology. You have to be able to support that technology and your company is clearly in over its head in that respect. And your written communications (such as this web site) are rife with grammatical errors. Your site desperately needs a copy editor.


How hard would it really be to sort the locks on display?

As it is, the locks show randomly, so I must scroll through 25 locks to find the one I want.
At least sort alphabetically, even if you don’t allow any other sorting options!

Overall, I have not been real impressed with v2.0 It did not make anything easier for us, and the new functionality it did add is problematic (We can add addresses and locations - what’s the difference? We do not have the ability to remove addresses or locations, and we cannot seem to move locks from one address or location to another)

Is there a way to change the address of a device? Not just the location at that address?

1 Like

App version 2.0.6 is not connecting to our lock. I am on a Google Pixel 6. Have tried reinstalling the app with no success. Please advise

I am having the same trouble on Apple

We have upgraded your bridge firmware, could you check if your bridge connect better?

No change. The connecting screen still persists

Hello, have your problem been solved by our call center supporter?
If you still cannot find your device, please check this FAQ: