Auto Unlock issues

I have the U-Bolt Wifi and was wondering whether anyone else has Auto Unlock issues. I would say it works 1 out of every 10 times. The other 9 times it takes so long to auto unlock that it unlocks after my 5 minute Auto Lock duration. I’ve tried all the troubleshooting options and had a ticket with support already. I was told to wait for v1.8 of the app.

Anyone able to figure out how to make it more consistent?


Same, it works for one or two ‘leave and returns’ and then nothing and it doesn’t even recognise I’ve left the area, let alone that I’ve returned. (yes I’m going far enough away, several km). I can turn it off and on again but same resultnor none at all. It’s a shame, it was one of the reasons I picked this lock.

Same issue, tried troubleshooting with support with various firmware and Android app updates but experience with auto unlock is degraded to the point where it presents a security risk – it will frequently only unlock the door after I’ve fingerprinted, come inside, closed the door, and locked it.

Trying out the new firmware today, but I don’t see any patch notes, so no reason to believe it will be improved. It is unfortunate as the auto unlock was the reason I purchased this particular device.

I’m having the same issue, starting around late February or so. Works maybe 10% of the time at best. Prior to that it worked perfectly. I too have tried all the troubleshooting steps. The auto unlock service notification appears on my phone when I leave, but never goes away when I get back until I manually close it. Occasionally when I return home, the blue light will flash, followed by the green light and the numbers lighting up counter clockwise like it usually does when it unlocks, except it never actually tries to unlock.

Also, while troubleshooting I figured out that if I reinstall the app or go into settings and clear app data, auto unlock will always work the 1st time after I set the app up again. After that first time, we’re back to the 1 in 10 chance that it’ll actually work. It’s very disappointing, as the auto unlock feature was the main reason I purchased this lock.

Mine’s never really worked reliably. I also see the blue light flash many times when I’m in front of the door. The door either does not unlock, or does about 2 minutes later when I’m already in the house and the door is closed, which is a significant security risk.

I worked with tech support whom replaced my Wifi bridge (i have the ultraloq pro) but that had no impact.


Thanks for your reply. I think the only difference is that I haven’t noticed the auto unlock opening the door several minutes after I arrive home. Although I did find the door randomly unlocked the other day and thought maybe I just forgot to lock it, now I’m going to have to pay more attention.

I have the same issues. Now, I have noticed that if reboot my phone, I then just open the app and unlock the lock with the app. Then the auto-unlock feature send to work fine, until the next time I reboot my phone. What I do still have issues with is it unlocking the door, I go inside, and several minutes later, after I have manually locked the door, it will unlock again. That part is very frustrating.

1 Like

Thanks, I’m definitely going to try that! I’ll report back if it works for me.

Rather than start a new thread, I thought I’d bump this one and see if there has been any solution. I just installed this lock and I am having the same experience as everyone else, the auto unlock never works except for the rare occasion when it will decide to unlock my door long after I’ve come home.

Auto-unlock is literally the reason I swapped out my old lock so if I’m going to keep using it I kind of need it to work. Maybe someone has figured a new trick to getting it to work reliably? I’ve already removed all battery restrictions for the app so it can run unfettered but that has not made any difference.

The only potential issue I can think of is that the persistent notification for the auto unlock service is grayed out. I don’t really think this means anything but maybe?

1 Like

My advice is to reach out to their tech support and repeat what you’ve said here. I spent awhile going back and forth with their engineering team giving them information and also offering to beta test any firmware or Android update. They sent me a new WiFi bridge unit but it had no impact. Haven’t really heard back from them since. I’m in the same boat as you as the auto unlock was the key feature I was looking for, and had I known this wasn’t going to be actively prioritized, at least among Android users, I would have gone with an August lock, even if it meant giving up other niceties about this one.

I’ve tried pretty much everything I can do and my conclusion is that the only variables that matter are the Android app version and the firmware version. The lock worked best when I first got it and I think several app and firmware versions later, auto unlock is effectively broken.

1 Like

Exact same issue I’ve been having, with the exact same troubleshooting steps I’ve tried. Knock on wood, but mine is suddenly 3 for 3 today and I haven’t made any changes.

Having same issues everyone else is reporting here. Key feature that doesn’t work reliably. Maybe 1 in 30 times I get home it will randomly work. Please address This issue

1 Like

Same issue here. Only time i made it work was linking it to smart things and creating a routine. Now that doesn’t work either. Ive tried calling tech support but the phone doesn’t work.

Same. App correctly reports I have returned home when I approach the driveway; however, the auto-unlock does not occur for several minutes, effectively rendering this functionality useless. I’ve done all recommended troubleshooting and settings are correct. As others have stated, this feature was a primary reason I chose ultraloq. All other features appear to work as intended. With so many reports of this failure, assistance from the mfc is expected and appreciated!


To add, I switched to an iPhone 14 from my old Android device recently and was curious to see if the iOS app was any better at handling it since it seemed like it got more updates. The answer is no, so the fix is either in the firmware itself or updates needed to both apps.

1 Like

Ditto, Auto Unlock does not work well. I think it is a combination of not staying unlocked long enough and not immediately unlocking when the lock sees the phone’s Bluetooth.

1 Like

+1 for same issue. iPhone 13 Pro. Bluetooth only - no WiFi hub. Like most others auto unlock is why I purchased. Come on U-tec - please fix!

I use this lock for my office so need people to enter freely during the day. I wish there was a way to lock and unlock the door using the keycode or fob and the door staying unlocked until the key or fob is used again. Is there a way to program this?

I’m having the same issue. Auto Unlock worked maybe twice in the 10 days since I installed. I’m on an iPhone 14 and all firmware is up to date. I get the notifications when I leave; I get them when I return home but the lock is playing dumb and doesn’t seem to get the message.

At this point, it’s nothing more than an expensive dumb lock that I’m considering returning to Amazon before the return period ends.


Feb 16 is the end of my Amazon return window. Shopping for new lock now to replace it. The Wyze Lock Bolt is in same price range but no key which is probably a deal breaker for me. Fingerprint is nice but hardware key is on my list.