Unit No longer working (bricked)

I’m currently on Beta app ver. 1.8.0 beta 23 on android. I was able to get the new firmware to install (however not the bluetooth firmware) last week i started to get the low battory warning (my non-beta test verison i have had installed for about a year with the same battories). The lock did its Auto lock last night, however today when i came home it wouldnt read my finger print. I then tried my pin and saw that no lights on the unit where working. First thing i did was put normall AA’s in as the utec ones i have on order. That didnt help, still no power. I then tried the micro usb plug with my backup power pack, again nothing. I then removed the back part of the lock to make sure no damage was done to the plug, again nothing. I believe the unit is now dead and not useable. I tired the reset button as well but with out power i dont think that is of any use.

Am i able to get a replacement? I hope to send back this unit so the R&D people can analyze the unit to find the sorce of the failure.

I have a pro unit that just bricked as well on an attempted software update (not beta). When I try locking or unlocking using the app, the lock gives me an audible tone acknowledging my attempt but no lock movement. I swapped it out with a new non-pro unit to get by until I can contact service to work on a fix.