Can't update U-Bolt Pro firmware to 2.26.0020 with beta iPhone app

I’ve been trying to update this lock for a couple of months and it won’t do the update. It starts the process from the phone, but the % complete in the new beta app never goes above 0% and then it fails. I’ve tried removing/replacing the batteries in the lock and resetting the app and restarting the phone. I have not yet tried resetting the lock completely. Any suggestions for how to get this lock updated? I have 2 other locks (same model) which all updated fine.

Here’s what recently worked for me:
Turn off WiFi on your phone, turn off and on Bluetooth, then update. It worked like a charm. I think there was an issue with the stagnant Bluetooth connection.

I’ll try that tomorrow. Just this evening, that lock stopped responding to any touch/keypad actions and the phone app can’t connect to it anymore. I changed batteries and the problem is persisting. Not sure why it just totally died on me now but the fact that it couldn’t be updated may point to a problem that has been growing. I’ll look at it more in the morning.