Ultraloq wifi needs daily reset

I have an Ultraloq WiFi and for some reason after a few hours or overnight auto lock stops working. I believe the sensor is working since the app detects the door opening and closing appropriately.

Lock spontaneously stops auto locking until I take batteries off and then on.

Also, I got auto unlock to work correctly once and only once.

This lock is bug ridden and not read for prime time. I’m ony second lock. First one just stopped working after a couple of weeks.

Hi, do you mean for sometimes when you close the door, the door status was right but the lock won’t auto-lock?
Could you tell me the following info for better troubleshooting: 1. Auto lock settings page, 2. material of your door and photo of sensor installation

Hello Carrie,

Thanks for your reply.

Yes, I do mean that sometimes when I close the door, the door status is correct, but the door won’t auto-lock.

My auto lock settings are as follows:
Auto Lock is set to on with the blue shade on
Door sensor is Paired.
Door sensor is set to “Immediate”
Relock timing is at 0s

This morning when I tried to reproduce the problem, I tried to use the app to see what the door status was and discovered that the app could not connect to the door. I also noticed the following:
Auto lock seemed to work when opening lock by hand.
Finger sensor not responding at all.
Opening the lock via the number keypad works, though the lights on the keypad don’t go on when touching the keys.

After, logging out and back in to the app the app then is able to connect to the lock and app is able to lock and unlock the door. But the finger sensor is still inoperable.

The door itself is wood. Attached are pictures of sensor installation.

Thanks again,


Because your keypad light is not lighting up when enter the keypad numbers, the possible reason is that the wire connection between the exterior and interior lock is something wrong. You can reinstall the lock to see if it is different. And also, when reinstall, pay attention if the extierior lock has rain water inside, in this case, it could also make the keypad and fingerprint not working right.

Try uninstalling and reinstalling the app.

I will try to reinstall the lock to see if that helps.

Thank you

So, I tried reinstalling the lock by removing the batteries, unscrewing the two interior screws, detaching and then reattaching the wires to the lock motor, interior screws, and batteries. This seemed to solve the problem. Fingerprint worked and I tested the auto lock and auto unlock features which also worked. For a while…

Later on in the day, I discovered that finger sensor no longer worked. Auto lock stopped working and the smart (not!!!) Lock began beeping incessantly every five seconds or so until I remove and then reattach batteries.

What is going on with this device?

For the record I’ve been having similar issues and I’ve only been using the lock for 5 days. It will randomly drop offline. I’m an IT engineer as well. I isolated the wireless 2.4g network to its own IoT SSID. I’ve had to remove batteries to reset wireless connection on lock 3 or 4 times. I noticed this only happens most of the time when auto lock is enabled. If the lock starts to engage the lock function and gets hung up for any reason the whole unit drops offline and needs to be reset. Hoping this is a firmware issue that can be fixed.