Ultraloq U-Bolt Pro WiFi spotty WiFi connection

Though my router is dual-band, from the router interface I could see that the lock could connect to the 2.4 GHz network. However, the connection between the app and lock over WiFi is spotty, meaning that it works sometimes, but not always. Many posts out here say that the lock is not supposed to work with a dual-band router. I could not find that clearly documented anywhere. Also, in my experience, it kinda half-works, which is weird.

I tried using a 2.4 GHz WiFi extender, but the lock did not even bother to connect to it.

Folks, how is your experience with the WiFi connection? Does it reliably work?

Hi Dipanjan,

We apologize for this inconvenience caused for you.

A ticket has been created for this issue, please check your e-mail for our detailed reply.

Thanks for your understanding.

While you may argue that a ticket streamlines the support process, at this point after seeing so many similar complaints, I totally feel like the ticket process is just there to keep the conversation behind the scene. I am following up with the ticket. Will update the outcome here shortly.

I am seeing the same problem. I have tried 2 separate WiFi networks and the 2.4 GHz is spotty at best. At least on the main website it doesn’t say there are limitations to dual band networks.

Exactly. In fact, from the router’s web interface/app, I see that the lock is connected to the 2.4GHz network

I don’t seem to have an issue with Google WiFi mesh system. Phone with app connected at 5g and lock at 2…4. Only had a little over a week, so fingers crossed.

Are you sure that you are connected through WiFi and not Bluetooth when you operate from the app? To be sure, you can turn the Bluetooth off and force the app to fall back to WiFi during testing.

Does your lock still work reliably over WiFi? I have the exact same setup, i.e., App connected to 5 GHz, Lock connected 2.4 GHz, dual-band setup over same SSID. Doesn’t work most of the times.

I upgraded to a dual band router 7 days ago. Right now, the IPhone/app is connected via the 5G and the lock is connected via 2.4G and everything has been working OK.

I have T-Mobile Home Internet. I created a separate 2.4 Ghz network with WPA/WPA2 security. My U-Bolt locks connect to it easily.

So I thought I would share this. I let my lock just sit and ignored it for the last week and have been testing it again. Now it is rock solid. Its connected to the network, I can unlock and lock from the app. When ever I go into the the App it shows connect to the WIFI. I have tried unlocking and locking off network with my bluetooth turned off and that is even working. The big problem is I don’t know what has changed in the last week.

I am experiencing the same. Initially, the WiFI was super spotty. Something changed in-between. Now, it works reliably when connected to my dual-band WiFi. Like you, I also tested it with Bluetooth off and even off my home netowrk. It works. But I am not happy since it totally feels like a coincidence. I am afraid it will recur in the future.

Do you use Alexa? The issue now is that if you use Alexa to lock/unlock the Ultraloq U-Bolt Pro, it won’t work. I think the problem is that the firmware is not compatible with the newly released version of Alexa (Released on July 12, 2023)

I don’t use Alexa. I did go to see if maybe a new Firmware was released for the lock and it looks like the same firmware when I installed.

I use Alexa. I shared my experience here.

Yes. No Wifi issues at all.