Ultraloq U-Bolt Pro WiFi does not work with Alexa

I have set up Alexa skill multiple times, and enabled both app-based and voice-based controls from the Alexa app.

Still, I have mixed experience. Sometimes the lock does not work with Echo dot/Alexa app at all. Alexa says that it’s locking/unlocking the lock, but nothing happens in reality. Sometimes, ONLY unlocking works, but locking does not. Super weird.

Folks, how’s your experience with Alexa integration? Does it reliably work?

1 Like

Hi Dipanjan,

This might be caused by the WiFi or Server delay. Please make sure your lock is in good connection with the WiFi network.

Please also tell us whether your lock passcode is 6-digits or 8-digits.

Waiting for your reply soon.

Hi Eli,

WiFi delay is impossible. It shows WiFi connection strength within the recommended range. The router is a pretty solid one. It has a few other IoT devices connected to it, all working flawlessly. Server delay is also out of question since I tried numerous times over multiple days. The lock passcode is 6-digits.

Sincerely, Alexa integration is one of the major reason I went with a smart lock. I took a look at the Alexa skill, it has got pathetic reviews, 1.9/5 IIRC. What do you think regarding everyone bad-mouthing about it? Do all of them have WiFi delay.

If your flagship product falsely advertises a key feature, I am afraid that crushes the confidence of the buyers. I planned to purchase a couple more smart locks, too. Unless this issue is resolved, Ultraloq is not having me as a returning customer for sure.

I am having the same issue. I have the fastest internet speed available and my router is only about 10 feet from the lock. Alexa says it is locking/unlocking but it doesnt. I bought 3 of these that I will need to return since I bought these specifically for the Alexa.

Can you please try them out and let me know? I am sure it’s not an WiFi issue. I am surprised how this brand got so many ratings in Amazon. Fooled us all.

Hi, Since a few days, Alexa is unable to issue lock/unlock orders to my Ultralock PRO with WIFI Bridge locks(I have 2).
Alexa is able to interrogate the locks i.e. it is able to know if the lock is in lock or unlock state. From U-Tec app, either from Wifi or Bluetooth, everything works fine.
Before making this post, I have read everything I could on the topic, also, for both locks, I have done the following:
Unpaired and re-paired bridge
Remove and re-added alexa skill
Removed and readded pairing between u-tec and Alexa
Android U-tec app version is
Ultralock device firmware version is 02.26.0020 on both devices
Alexa version is 2.2.521848.0

Please Advise.

1 Like

Mine is the integrated WiFi version, yours is probably different, the bridge one. In my case, initially Alexa was unable to take any action. Now suddenly, on one morning, it somehow got the super power to unlock the door with voice commands, but locking is something Alexa is struggling with (never works).

My Ultralog now has exactly same problem as yours. The problem has apparently first appeared on July 12 after the Alexa was updated to the current version on that day. I think Ultraloq needs to update its firmware to make it compatible to the current version of Alexa.

I am having a similar problem. I ask Alexa to lock the front door and it responds ‘locking, hang on’ then ‘hmm front door is not responding’. Up until a week ago this worked flawlessly. I tried deleting, re-pairing, resetting and nothing works. The U-Tec app works fine. It is only the Alexa interface that doesn’t work.

1 Like

All sorts of variation of the same problem. In my case, unlocking works through Alexa voice command, but locking does not.

Where is Eli from technical support? Eli, it has been 13 days since you replied to our posts. Can you give us an update, please?

1 Like

Eli hasn’t responded to me about the Alexa issue. I created another thread regarding spotty WiFi connection. He has sent me a replacement part, but I haven’t tried that yet, since the WiFi has magically become reliable lately (see the linked post). I don’t know yet if swapping out with the replacement would solve my Alexa issue.

Which Alexa version are you currently running?

From the Alexa app on my iPhone - Build Version: 2.2.548660
App Version: 2023.15

If the “Build version” refers to the build of the firmware, then yours look very different from mine. From Alexa app on my Android, Devices => Echo & Alexa => Echo device => Settings (tor right gear icon) => About => Device software version = 9094444164

My build version more closely matches user northwestfrog with Alexa version 2.2.521848.0
again, my version: 2.2.548660
I should point out that my U-Bolt Pro lock firmware is same as others: 02.26.0020
The U-tec app on the iPhone works flawlessly, although the screen display of status could use an update. When you first start the app, it shows a status if Unlocked. When you press the screen you would expect it to lock, but instead shows ‘connecting’ and then the true status of ‘unlocked’. Successive presses then locks and unlocks as expected.

Do you think technical support has given up on this thread? Should I open a new thread that may prompt a response from technical support?

How are getting the build version? According to the Amazon website, I am on the latest firmware version of Echo Dot Gen 3.

If you decide to open another thread, please share it here. I’d like to follow that as well.

I have no idea if this is the correct way to get the build version, but here goes:
Start Alexa app on iPhone
click ‘More’ at bottom right of screen
click ‘Settings’
scroll to bottom and click ‘About’
gives me:
Host Name: na-api-alexa.amazon.com alexa.amazon.com
Client Version: (nothing displayed)
Build Version: 2.2.548660
Serial Number: FBBF7136…
App Version: 2023.15
I asked Alexa to give me its version and it said to check the app.

According to this, my app’s build version is 2.2.521848.0 and app version is 2023.15

But this is related to the version of the app running on your phone, not the firmware running on the device.

Can you try getting the device software version like this?

  • Open the app
  • Got to Devices (bottom)
  • Choose Echo & Alexa (top)
  • Choose the Echo device
  • Click on Settings (the gear icon at top right)
  • Scroll down to About
  • Read the Device software version

from my living room echo - 9094444164
from the kitchen echo show - 9094443652
It doesn’t make a difference on the response I get from Alexa.

I opened a ticket with support. Listed as request 154368. Hopefully that avenue will be fruitful.