U-tec APP cannot login on my iphone

I just bought the u bolt pro, however I cannot login U-tec APP on my latest iphone, I tried both on my fiber internet or data, what can I do?

Having the exact same issue. Just installed it went to the app kept saying failed to connect to server so I got on computer to create my account and now when I try and log into the app it’s just “loading”.

Yes, that is my issue too! I wonder if the server is under maintenance or something then. Hope someone else can answer

Same. Went to create new account on iPhone and it said ‘Can not contact server’. Created account on laptop now logging in just has ‘Loading’ spinner.

I just installed my first lock, not a good look stumbling out of the gate like this.

Attempted to file a support ticket but when I hit the submit button, it just put me back to the main support page. No idea if it actually created a ticket. Ugh.

Same issue here…

The app is not working for creating an account (cannot connect to server) or when trying to log in (spinning wheel).
I was ultimately able to create an account via a web browser, which is how I can post this, but the app remains unresponsive.

I just bought two of these and cannot install them until I know this is fixed. I am wondering if it’s a bad sign and I should simply return them and get another make?

Just filed a second ticket, I think. I’m not on Twitter but maybe someone else can tweet at them. It’s been at least two hours. This is unacceptable for a product that you would imagine 95% of people are installing over any given weekend.

As a professional nerd, a tech-based company like this needs at least one person on-call at all times to triage tickets. Secondly, I’d question their internal monitoring that a complete outage has been going for at least two hours with no acknowledgement.

The lock itself feels high quality, support/IT at U-Tec, amateur. So irritated right now.

Where to file a ticket? I didnot even know this function…

I tried again, and was able to login! I think their server might be down

Just retried and it seems that is back up and working. I do worry that there was no update provided here acknowledging an issue! A simple “we are aware of a problem and are investigating. Sorry for any inconvenience” would have been good enough.

Problem solved, sorry for any inconvenience. :sweat_smile:

1 Like