U-Bolt Pro Wifi only sending Wifi transmission one-way, when the lock is physically rotated

I will also send this as a ticket support directly to the team, but I wanted to describe this weird behavior to the general forum too.

For the past few weeks, I have not been able to interact with my U-Bolt Pro Wifi using wifi, only using Bluetooth when physically present.

Using the app, I can not lock/unlock, add users, view logs… Essentially I can not access any of the lock’s internal data on wifi (only out-of-date cached data that populates the fields in the app). The app says WiFi is enabled, connected, Signal State is good (-46dB). But overall the whole app experience behaves as if I am not connected with the lock via Wifi.

But here is the STRANGEST thing. And I think this is the most telling piece of bug testing I can provide. When I physically lock the lock by turning the dial, the app’s homepage on my phone (bluetooth off!) will update the lock status in the app within 1 to 2 seconds. But the same status inside the inner app does not receive the live updated lock status (you know how they recently added a new pretty wrapper app to the old app, and the old app still runs inside the new homepage app?) This means that the device is in fact connected to wifi, can send outgoing messages, and the homepage of my app on my phone is picking up this changed state information. But I can not send commands over wifi.

Is the device only waking up and turning on its wifi radio when I physically turn the locking dial, but immediately going into some sleep mode and not listening for incoming wifi-sent messages? Is the new wrapper app able to listen to wifi state changes, but the older inner app can not/broken?

The whole thing works flawlessly over Bluetooth, but as everyone here knows, that is not why we bought this device.

U-Bolt Wifi Pro
Lock Firmware 01.38.0023
Bluetooth Firmware 00.06.0050
App version 3.1.0
Batteries are brand new.
Wifi router is only in 2.4GHz mode.

I have the same issue with the same lock and firmware. Also to add to it, I have amazon alexa connected and it locks and unlocks the door just fine

1 Like

Assuming your goal is to get things working and not to figure out why, you should systematically peel back the layers of this onion. For me, this would look like:

  1. turn off your phone and restart after 10 seconds. If still not working…
  2. delete and reinstall the app. If still not working…
    3a. delete the lock from the app and then delete the app
    3b. do a factory reset on the lock and remove the batteries.
    3c. reinstall the app, insert the batteries in the lock, and do a clean set up of your lock.

If the lock behaves normally with Alexa then it is likely that app/phone that is messed up, not the lock hardware. Just a guess.

I agree. I did steps you suggested up to 3a with no changes. Was about to do a reset but support decided the lock is defective and are shipping a new one.

Personally think its something in the app… I guess I’ll find out when the new one arrives.

I’ll give an update when it arrives.

So, as soon as I sent the message my app updated to 3.1.1 from 3.1.0 and it is now working

I can’t imagine why support would suggest the lock was defective, given it works with another app (Alexa). Oh well.

Are you iOS? I don’t see that update (yet)

No Android. Sorry for not mentioning that first