U-Bolt Pro + WiFi Bridge Shows Incorrect Battery Level in Samsung Smartthings

My U-Bolt Pro + WiFi Bridge has started reporting an incorrect battery level to my Samsung Smartthings hub.

I have 2nd U-Bolt Pro WiFi Smart Lock and this is correctly reporting its battery level to the same Smartthings hub.

This was working correctly and only started working incorrectly some time in the past six months (possibly around the time that the U-Tec app was updated or perhaps a Smartthings Update?)

Things that are working:

  • Both locks are showing the correct battery level in the U-Tec iOS App (even when bluetooth is disabled on the phone - so the right battery level is making it to “the cloud”)
  • Both are showing the correct lock open/close status in smartthings (so some part of the integration is working correctly to smarrthings for both locks)
  • Both locks can be remotely controlled from smartthings

Since everything works correctly for the Wifi Lock and given that the battery status is correctly reported by the lock using the bridge to the iOS App it would suggest that the problem lies in the Smartthings integration code specific to the U-Bolt Pro that uses the bridge.

Things I’ve tried:

  • Replacing the batteries
  • Removing and then re-adding both Locks to smartthings.

This is problem because I receive alerts from Smarrthings regarding the incorrect low battery level and I rely on these notifications to know when the lock batteris on both locks need to be replaced.

Thanks! Other than this - I’m a big fan of the products!


1 Like

Have you had any luck? I’ve had the same issue. I use SmartThings to incorporate it with Home Assistant but because SmartThings has the wrong level, so does Home Assistant.

I’m in the same boat - I’m also using Smarrthings as a bridge to Home Assistant where I have some convenient automations for handling low battery notifications.
And still no joy on getting a correct battery level for the lock that uses the wifi bridge while the pro wifi model lock is reporting battery level fine. It’s infuriating.

I completely agree. The only reasons I went with this lock was the affordability and supposed linking with HA. It’s not major but I do agree that it’s extremely annoying.

@Nicholas2 We are so sorry for this inconvenience caused for you. Would you please click here to submit a ticket? So that we can better help to to resolve this issue.