Two defective locks in a row?

I bought a U-Bolt Pro that was only being recognized as a U-Bolt, so I was not able to set up a fingerprint. I tried all of the troubleshooting and resets, and nothing worked. It seemed to be defective hardware because I couldn’t even get the passcode option to work. The app worked relatively consistently, but one time it completely lost connection until I power cycled it, so I couldn’t even trust that. Thankfully I had brought a key with me.
So, U-Tec sent me a replacement exterior assembly, and it’s the same situation. Right away, I didn’t have the option to use a fingerprint within the app. The only difference is that sometimes the passcode works with this lock, but still not every time. I never see the ring light up. The app unlock works consistently. I tried a few resets, and the same thing. The firmware is up to date.
Has anyone else seen this? I’m waiting for a response from support after receiving the end lock, but I’m quickly losing faith in this product.