Terrifying scenario

A couple of nights ago, I was watching TV in my flat in the early hours of the morning & I heard a familiar sound behind me. I realised it was the sound of my Ultralock unlocking. It was terrifying because at that moment I felt that a stranger was on the verge of entering through my front door. First I checked the lock’s position & it was indeed unlocked. After waiting a few more heart stopping moments I opened the door to find that no-one was there. Then I quickly locked the ultralock manually. I checked my Ultralock wifi bridge, it was still showing a steady green. I checked the app & my settings hadn’t changed. Everything seemed in order.

The logical questions follow: has this happened before? Perhaps when I was asleep & blissfully unaware? Was this the first time? Luckily I have the app set to auto lock after 1 min so if it did happen it would re-lock. But a minute is more than enough time for someone to get in. Can the ultra lock be hacked from outside to allow someone enough time to get in?

I find this more than ironic - to feel unsafe AFTER installing a LOCK! And it was not a cheap lock. I had it professionally installed around 18 months ago. I now make sure that my outer screen door is locked when going to bed. But this scenario is disturbing at best.

U-tec should put this sort of issue at the highest priority level & fixed ASAP.

I live in a ground floor flat as part of a 28 flat complex so it’s a pressing issue for me. I’m now in a situation deciding whether to ditch the lock or continue to hope this doesn’t happen again.

Has anyone else had this happen & if so how was it fixed?

you said you checked settings, but it’s unclear from your post, whether you checked your log listings to look for a mystery activation… I’ve had incorrectly labeled entries, in the log, on rare occasions, but never had non-entries in the log… meaning, every open/close of the lock registered an entry in the log… notwithstanding the separate log issue I had recently, but that’s been resolved… my issue there, was the app not showing any more than 5 entries per day…

Yes have checked log listing. The activation at 1:44 AM was caused by the APP as shown by the phone icon/APP unlock in the listing. Even though it names me as the owner I was not near my phone. This is worrisome because it is random. Had I not previously set the auto lock feature in the settings for 1 minute (also shown in the listing), who knows how long the unlock state would have remained - a minute, an hour, all night?? It is troubling too because it happened during the night when normally I would have been asleep. On what basis does an app trigger an unlock? That’s a pretty bad flaw in my opinion for a SECURITY lock.

I have made a screenshot copy of the entry which also shows the 1 minute auto lock at 1:45 AM. The manual unlock at 2:05 AM was me testing the unit to see if it would lock again.

This is the log entry:


Adding to my last post:

According to the log listing, there have been 5 events in total in February this year when the APP unlocked the lock: on 13th, 16th (twice), 18th & 19th to date. On two of those occasions I wasn’t even home. My listing does not go further back than 13th Feb so don’t know how long this has been happening. :astonished:

I would delete my account and create a new one. Did the person who installed your lock also create your account? Either way U-tec support should get involved to investigate.

The installer only installed the physical lock. I created my & my wife’s accounts. All seemed to be OK. I haven’t deleted our accounts as yet. Waiting to see what U-tec is going to do. They have come back to me pretty quickly & have gone through the usual troubleshooting. Fair enough. But I’m not trusting this lock right now. Not sure if I’d rather it be a mechanical issue & the lock replaced, than an APP issue that has hidden bugs that could bite any one of us at any time! Will update after I talk to them on the phone coming up.

1 Like

You didn’t mention whether you use auto-unlock. Also, do you have a wifi lock or just a BT lock, perhaps with a bridge?

Yes I had auto-unlock set up. As far as I know it only kicks in when you approach the lock from the outside not inside. The u-bolt pro I have has both wifi (for GPS/remote access) & bluetooth (locking/unlocking). It’s the model that uses an external bridge.

I couldn’t get u-tec on the phone when I rang them but did get another email from them. They will be replacing the lock. When they do I will delete my account & create a new one as was suggested above. A replacement helps, but I’ll always have a niggling feeling hoping it’ll never happen again. If it does I’ll be asking for a refund.

There you go. That is the problem.

Auto un-lock is full of glitches, from personal experience.

I don’t remember reading anything about Auto Unlock triggering when you’re INSIDE the premises & not actively using the lock. Usually Auto Unlock doesn’t work for me when trying to get IN. Yes Auto Unlock has many glitches but not heard of this particular one before. What problems did you have with that function?

I find that auto-lock is terrible. First, it very, very often won’t auto-unlock. 2nd, sometimes it does auto-unlock, but it takes so long to get the blue light ring and then for it to auto-unlock that I just use my finger. What is worse from a safety point of view, is that after I’ve used my fingerprint to open the lock it often auto-unlocks about 20-30 seconds afterwards. Since I have auto-lock enabled, it does then re-lock itself, but, of course, this should never happen. This doesn’t happen each and every time, but it happens, very, very frequently.

I have had a few random unlocks that then re-locked.

I also have an issue with the auto-lock (I have the Z-Wave lock and sensor installed) is that if the door is open it still auto “locks” (i.e. throws the bolt). That shouldn’t be happening as the door being open should override the auto-lock.

Here’s how AU works - step 1: your phone senses that you have left and returned inside of the geofence, the app is “primed” to unlock the lock. This has nothing to do with your lock, it’s just that app watching your phone’s GPS.

Step 2: when your phone gets close enough to your lock that it senses the Bluetooth pairing, your phone sends the same unlock command that you would do by pressing the big lock/unlock button on your screen. Note that the phone has no way of knowing if you’ve approached the lock from inside or outside your house, so if you come home and enter from a door out of Bluetooth range of the lock, the door will not unlock…UNTIL you get close to it from the inside.

Here’s the issue with auto unlock. The phone/app seems to prefer the connect to the phone using the WiFi channel (in your case, through the bridge), so when you are returning home the phone joins your WiFi and never, or at least not in a timely fashion, “sees” the Bluetooth pairing. Not seeing BT, it doesn’t send the unlock command. It is like walking around with a cocked revolver, waiting for the trigger to be pulled. At some random time, your phone may finally acknowledge that it sees the lock’s BT and, at that time, sends an unlock command.

this situation is exacerbated by the lock’s apparent inability to communicate over wifi and BT simultaneously and/or acknowledge a second device’s BT when actively using BT with one device.

There are two hacks for locks with bridges and one for locks with built in wifi.

Hack 1 - for all locks. put your lock on a separate wifi channel (for example, a guest or IoT channel) from your phone. That way, the phone will not join the lock’s wifi channel when you come home.

Hack 2 - for bridged locks - simply unplug the bridge (at least while you are out of the house). This prevents the lock from connecting to the phone over wifi AND eliminates the bridge from tying up the lock’s BT channel when Utec’s servers want to poll the lock status. Of course, this does mean giving up remote access to your lock while you are away. You might want to use this hack only when you are locally out of the house since, generally, remote access is less important when you are around town than when you are out-of-town AND auto-unlock is more useful when you are in and out of the house around town. When you are out-of-town you are not unlocking the door!

For my bridged lock, both these hacks work to provide AU reliability almost 100% of the time, with hack 1 only “failing” when the servers are doing a status check at the exact moment you are approaching the door. I have no direct experience with wifi locks but I expect Hack 1 should work for them.

BTW, a simple time-out patch for autounlock would eliminate the delayed unlocking. The app would just cancel the autounlock if it did not happen within, say, 5 minutes of you re-entering the geofence.

Yes I had that same issue when approaching the lock from outside. The blue ring light would take quite a long time to come on. In a previous conversation I had on the phone with U-tec they suggested I modify my Location for the lock in the APP to a further point away from where it was located. The reason for that was because the Auto Unlock was being triggered too early & by the time I actually got to the lock it had auto locked again (this was set to 30 secs). So when I’d get to the lock it would appear it hadn’t worked at all, but it actually had, & had relocked. It was suggested I alter this to a longer time pause which I did to 50 secs. So this as well as the Location change made the Auto Unlock work more predictably - not perfect - but much better. Hope that might help you too if you are still having that problem.

Thanks Bruce for that detailed reply & hacks . In my particular case, I live in a smallish flat with only one entrance in or out & I’m often taking my iPhone with me when moving about the flat. This necessitates me always to pass by the door of the flat that has the lock attached, as well as the bridge nearby (bridge is about a metre away with direct line of sight of the lock). I should be triggering it all the time! But touch wood, I’ve never had the Auto Unlock triggered from the inside. That’s why it was so disturbing that the lock spontaneously unlocked when I had been sitting watching TV in the early hours of the morning for some hour or so without the phone being even near me. So this Auto Unlock moment happened randomly & UNPROVOKED by any physical activity on my part as I’d been in the flat all evening. And as mentioned in my third post, Auto Unlock had on two occasions been triggered even when I was in town, nowhere near my set GPS area. :thinking:

I agree that the bridge has trouble when both my wife & I approach the door from the outside – Auto Unlock gets confused when both phones are there. She has the APP on her iPhone as well. Then auto lock doesn’t seem to want to work at all. And when testing, I can only do so with one phone at a time.

You mention in your last paragraph about a simple time-out patch for Auto Unlock. Could you please explain how I’d do that?

Didn’t mean to suggest that the “patch” was available. they are working on a replacement app, now in beta, and “we” beta testers have suggested it include this time-out feature.

Thanks for looking out for us! :grinning:

I just today received u-tec’s replacement, what they call Exterior Assembly V2.0. The bit that has the numbers in a circle, finger sensor, & a wire coming out of it. Not sure if this’ll make a difference but it seems they have determined this piece to be the culprit. We’ll see. Will replace this part today & keep an eye on the logs for any event that shows an unauthorised unlock. Happy with the speed of the replacement. However, if the lock repeats the unlock issue even once it’ll be refund time!

Thanks everyone for chiming in.

Sent me wrong part. :face_with_spiral_eyes: :face_with_spiral_eyes: :face_with_spiral_eyes: Should’ve been the Inner Assembly. Now waiting for that…

Epilogue: received a whole new lock from u-tec & have been testing it for a few days. Replacing the lock was easy. After removing the previous device from the APP on my iPhone the new one had to be installed from scratch but once it was it worked perfectly. The connection to the bridge is stronger & not flakey as before, even Auto Unlock works consistently. No phantom unlocks have occurred & now both fingerprints work - I could only register one before. I can only think that some fault with the interior assembly was causing a number of issues to surface. Very happy that u-tec resolved this issue quickly & gracefully.

Which app are you using - the old one or the new U-tec Home app?