L5 on phone app, can't connect to Wifi on Air?

So activated two (2x) Latch 5 fingerprint on iPhone App. Worked fine. Decided to convert to Ultraloq Air on my property. Deleted the device from app, Activated Ultraloq Air, Reset lock to Factory Default with paper clip, removed batteries for 30sec to be sure, and started over. First lock went fine, 2nd lock will not connect to wifi. Triple checked the password. Went through the reset procedure mentioned above 2x more times. Still will not connect.

Any ideas or things to try? I’ve sent in a support email, but I “assume” that support is overseas as it only responds at night. In the meantime, I would see if there is any local USA folks that have encountered this before?

You may want to check the Firmware on the Latch 5 that doesn’t connect. If it’s an earlier version compared to the successful one, then you may need to install it on App first, update the FW, remove from app, and then set it up on Air. You may want to contact support if it still doesn’t work. 1844 HEY UTEC or support.u-tec.com