Firmware Update Error

Just got the WiFi ultraloq. After the initial install and setup lock is working fine but I can’t update the firmware. Please see the attached screenshot.

I am using the test flight version of the app, if that matters.

Anyone else having this issue?

Saw the same thing.
My lock installed as “U-Bolt Pro WiFi” for some reason. Otherwise saw the same thing. It failed with 52s remaining on the update.

Is V00.04.0050 the old the version, and it failed to update, am i right

Looks like that’s the new one, see the screen shot.

I have the same error. It won’t update the Bluetooth firmware.

Bluetooth fails to update, stopping at 1 minute. Multiple attempts.
Will try again a few more times.

I had similar issues with mine. The target firmware displayed on the screen before any update attempts was V00.04.0050.

The first attempt at firmware update quit about 51%. No error messages were displayed, and it just stopped.
Second attempt seemed to update the firmware, but it wasn’t the expected target version. The firmware update screen showed “Update is done. The current version is V00.04.0050.” However, the firmware screen showed version 00.03.0050, which is higher than what I started at.
I ran it a third time, and the screen showed that the update was successful. The firmware screen shows that i’m now on V00.04.0050.

Now that I’m on the latest Bluetooth Version, there’s still an “Update” button. I feel that this button should disappear if I’m already at the latest version. (Screenshot below).

1 Like

Same here, multiple tries at updating Bluetooth firmware, none successful.

Downloaded the new test flight update today. The update ran without and error and I got a “Success” message finally.

Except it didn’t update. The app still says I have the old version and I can run the update again and again. It says successful every time but doesn’t change the actual firmware version.

Scratch that. After a few app restarts it’s now properly updated and showing the latest firmware version. Maybe a small bug there where you can run the update over and over until you quit the app.

We just launched new ios app version in test flight today fixing this firmware update error issue.

1 Like

It works. Small bug, if you don’t exit the app you can keep running the update.

Is there a new app for Android coming out soon as well?

It looks like the app reported that my Bluetooth firmware was updated when it wasn’t.
I updated the bluetooth firmware a few times and the app eventually showed that it was at the latest version. However, I disconnected and re-associated the door lock wifi and the bluetooth firmware shows the old version again.

This is what my firmware looked like prior to disconnecting wifi:

This is what my firmware looks like now (after resetting the wifi ssid in the app):

I tried about 13 times and it failed. On the new version, it failed once then it worked. Like others already mentioned after update the screens show the old version. You have to go out then back into the update screens to see the new version is applied.

I too am having the same problem. I have even removed the battories for 5 mins and tied again with the same result

Are you using the latest beta app version? 1.11.5? It should work with that version.

Am i missing something? Im on android and have the updated verison from the google play store. Showing to be ver. 1.8.0 beta 20? Something i need to do to get the updated app?

Sorry, my comment was for the iOS beta app. @Frank any plans to push a new version of the android beta app?