Can't add fingerprints to new Bolt Pro UB01

I tried to replace a dead UBolt Pro with one that I had recently purchased to put on a different door. The install went fine and I added it to the app but I can’t add a password to any user. When I try, I click the “Start adding a fingerprint” button in the app and the app shows the circles for each attempt, but when I touch the device, it beeps red and the app pops an error about a timeout. The keypad seems to be also registering this as a failed unlock attempt (because that fingerprint doesn’t exist in it yet). Looks like the app is trying to tell the lock to go into “add fingerprint mode” but the lock is not receiving that message. This makes the lock only useful for combinations.

I tried doing this with both the beta version of the app as well as the current one in the iOS App Store. I also tried factory resetting the lock and setting it up again. Same problem. I tried creating a non-owner user – same problem.

Lock firmware version: 02.26.0020.
Beta app version 2.0.3
App Store app version 1.12.4

EXTRA annoying since this lock is replacing one that just died.

If the problem still persists with adding the fingerprint, could you please record a video of how it happened to customer service or here in the community.

I have a video of it but it doesn’t look like video uploads are supported. Suggestions for how to get it to you?

Hi, you can upload the video to google drive then copy and send the link

OK, here’s the link

Our customer service will contact you today. There seems the conneciton itself is fine. Is this lock a new one, or with the exterior part replaced.

This is an all new lock that replaced a failed lock. Both the inside and outside units were swapped.