Built-in Wifi lock version

I bought this lock to control remotely and it seems whenever I need to do something the connection to it just doesn’t work. I can reset the lock by removing the batteries and the Wifi then connects and shows a “great” connection status and remote control works at that point but then invariably fails when I need it most. It’s been quite a disappointment, I want to support small tech companies but if the feature I need it for fails so often what’s the point. Whether or not this is an inherent hardware design or firmware issue it’s hard to tell.

Lock firmware: 01.26.0023
Bluetooth firmware: not listed
Android App: 1.8.2

Update: Amazing that it started working again right after I sent in a ticket and this topic. If I go into the “Wifi Settings” page I get a “Good -41dB” status. I do have a question I’ve been meaning to ask.

Does the lock need to “phone home” whenever I want to control it, meaning does it connect to U-tec servers for full control?

Another update :slight_smile: Seems as if a new firmware version was “pushed” 01.27.0023, perhaps I’ll have some luck with this version.

1 Like

I have the exact problem. It got so bad I removed the lock and reinstalled my Nest lock. I couldn’t add users etc remotely for my rental unit so I drove 6 hours to be on the same WiFi as the lock and still get the same results even after updating the firmware.

Likewise “smart” notifications only work about 25% of the time.

I would really like a refund as it doesn’t work as advertised.

1 Like

I am having the same problems. They sent me a new lock, which I installed and it behaved the same way. They are now sending me a THIRD lock, and we’ll see if it’s any better. But, it really seems like it is likely a firmware problem - I assume the Wi-Fi is going into standby mode and never coming back out. If this third one doesn’t work, I’ll probably ask for a refund and try my luck elsewhere.

Hi, thanks for your feedback. Could you please tell me how far away you are from the lock when this happens? Does this problem occur on both long-distance and short-distance connections?

The issue is with the lock disconnecting from my Wi-Fi, not my phone (I can observe the that the lock disappears from my router’s connected client list). The distance of my phone from the lock has not impact on this. The lock is about 20ft from the Wi-Fi access point with no walls in the middle, and the SSID is 2.4GHz only, and the signal strength is listed as good.

1 Like

Precisely
The U-Lock Wifi intermittently appears in the disconnected list and disappears from the connected list…for no reason.
It is the only IOT device that acts this way. Lights, power outlets, cameras never disconnect.

1 Like

To me this seems like a hardware design problem, a new lock with the same hardware will not fix this, if firmware was this issue I assume it would’ve been fixed but perhaps they don’t have the bandwidth to deal with it.

After U-tec downloaded new firmware “01.27.0023” which most likely performs a reset on the lock the remote connection worked for the several days I needed it. This morning I needed it and I no longer have connection. My opinion is that the hardware / firmware just stops working after some time and needs a reset. I’ll do that when I get home today, it really is frustrating.

Since it does seem to work for a few days before needing another reset why not just code it in the firmware to perform whatever reset does. My guess is the wifi module they put on this device is cheap ass stuff that needs constant attention and disconnects intermittently.

1 Like

Hey guys, I’m very sorry for the bad experience. We will focus on observing and troubleshooting WiFi connection problems. Thanks for all your feedback.

I would like to add that another firmware update “01.28.0023” was pushed yesterday. As I mentioned before updating firmware most likely resets the lock so as of now the remote connection via wifi is working but it would be interesting to see a sort of “release notes” on what was done with the new version(s).

That’s a feature that we will consider in the following version. Thanks for feedback.

I’d be curious what type of router you and others with this issue are using. While I have not had the problem you describe with my lock, I have seen this type of behavior on other iOT devices. For me, going into the router controls and setting the ip address manually frequently does the trick. I think some devices have a hard time with routers that reassign addresses frequently. Just a thought.

I have the Google wifi mesh system, the lock shows excellent connection to the main wifi point but it loses connection all the time. It’s quite irritating as I really want to like this product but there are issues, my guess is the wifi module they are using is sub-standard / cheap.

At this point, months later, as I’ve not had to use the remote feature in quite a while I can’t confirm it hasn’t worked since the last time I posted but as I brought it up this morning I was greeted with a “Network disconnected” message when trying to bring up the logs and all my users seems to be missing. Still on 1.28.0023 firmware.

I still haven’t been answered to the point if this device “phones home” to Utec servers

When I try to bring up the Wifi settings I’m greeted with a dialog box labeled Notice that says “Unknown error”, so yeah all sorts of screwed up here.