U-tec app does not send notification to new iphone

I got a new iphone. I migrate all my data to the new iphone.
I have smart notification created before the migration. The notification never get sent to the new iphone. Only the old iphone received the notification.

Here are things that I tried

  • I logged out of the app from the old phone
  • I recreate the smart notification in the new phone
  • I checked that the notification is enabled in the iphone settings.
  • I toggled (disable then enabled) the notification in the iphone settings.

I tried all the above and I still did not received the notification on the new phone. The notification always go to the old phone.

I have app version 2.0.6 on my iphone.
My u-lock has 02.26.0020 firmware version.

Please delete the notification settings in the old phone, log out and do not log in again.
Log into the new phone with APP Version 2.0.7 in app store, then set up the smart notification
in the new app and phone again.

I did not see app version 2.0.7 in the app store.

I deleted the smart notification from the old phone app, logged out from the app. Then logged in to the new phone and recreate smart notification. Still did not work.

We released the version in Jan.14th, please check again.

It still does not work. I have the app version 2.0.8.