U-bolt WiFi Pro setup/installation process... horrible software!

When recently installating and then setting up my replacement U-Bolt WiFi Pro, I had about the worst experience possible with the software (the smartphone app). Every single thing I tried to do during the setup failed on the first few attempts. I kept getting ‘Admin login timeout’ notices in the app. I also encountered many, many ‘Fingerprint registration failed’ messages during setup. The U-Bolt WiFi Pro also became completely unresponsive to any input (phone, fingerprint, physical buttons, anything) twice during the initial software setup process, requiring me to remove batteries and reinstall to get it responding again. The doorjamb lock position sensor also seems to not work at all now. The app seemed to recognize it during the setup process, but the ‘Auto-lock’ feature is not working AT ALL. I think you guys have maybe disabled it within the app… why not add a note to the app or grey out the feature? Makes no sense to disable functionality and then give the user no idication as such. Back to the terrible setup process though… the app was failing on everything I tried to do on the first or second attempt. Add a user… failed. Add a fingerprint, failed. Add a second set of fingerprints after finally getting one finger setup… failed. Adjust settings for the lock, failed. I must have restarted the app a dozen times in trying to initially configure the lock settings and add my basic group of various users. I don’t believe I’ve ever had a worse iniitial setup experience with a piece of software and hardware… and I’ve had some doozies. You guys need to put a LOT more QA time into your setup process. The bluetooth communication between the devices seems flaky and the software seems super easily confused. I found that it was pretty much impossible to add a fingerprint and then immediately add another one. It would pretty much always fail. I found that I had to totally back out of the lock and start over if I wanted to program a second fingertip. Please put a LOT more time into testing the initial setup process. What should have been a pleasant and enjoyable 10 minutes or so, ended up taking me numerous restarts and probably close to an hour. Simply rediculous! Very poor software programing!!!


Have pretty much have had all same issues. Worst electronic install process ever. The keypad doesn’t work or is erratic. The Wi-Fi and Bluetooth work erratically. The device doesn’t respond in app. Support just sends an email with a long convoluted checklist. I can’t get by connecting with Bluetooth only. Have already spent way too much time on trying to get this to work. It should take me longer to install the mechanics than to set up software/hardware IMO.


It seems likely that the particular lock has something wrong with the connection issue. Could you please contact customer service to get replacement

@Snyder We apologize for all the inconvenience caused. Please check your email to get the solution for those issues. The ticket number is 116939.
We look forward to resolving the issue for you soon.
Please do not hesitate to contact us if we can further assist.

This is my exact same experience. Admin login failed. Admin login failed. I have to try everything 10 times and reset the app. And that’s only on Bluetooth. Wifi won’t work. Period. Wifi is in the product name… but doesn’t work at all. It connects on setup and tells you that you are setup to wifi. It shows a strong connection. But if you try to unlock it then just says “connecting” and spins forever until you reset the app.

So then you connect via Bluetooth and, as you said, can’t enter more than one finger at a time without backing out of the app and retrying . And hope you don’t get the “admin login failed” error because then you can’t do anything at all with user management.

Both the hardware and software are horrible and I’m offended that I payed 350 for this. Support blames it on your wifi and send a giant checklist. I’m on 2.4 wifi… it’s not me. The device and software just don’t work.

1 Like

I’m now having the ‘Admin login timeout’ issue. Is there a fix for this?

Berry, the fix is probably for U-tec to correct their software. I still experience the ‘Admin Login timeout’ error message often as well. Happens with differrent locks. In my experience it doesn’t stop me from checking or adjusting settings, it just makes the process take longer than it should have to. Hopefully U-tec will get this issue fixed at some point.


I always get a time out message when adding new users, it seems to take an eternity every single time. Very frustrating and I can’t seem to find a work around or create conditions to avoid this glitch.

Notice - Time out, please try again