Time is off since Daylight Saving Time and Log not populating since then, too

I’ve tried to follow some of the suggestions on here but under Settings the only option is Connect Bluetooth. U-tec sent some links and told me I’d have to figure it out myself.

1 Like

I have a same problem. my logs are 1h off now.

1 Like

my logs are empty and it keeps saying “admin login failed” Help??

My logs population works intermittently, based on pure luck I guess, every second time log is empty .
Than I hit retry once in a while it might populate if stars align.

“ADMIN LOGIN FAILED” and time did not adjust for Daylight Savings Time. Just got off the phone with Utec and this is what worked: I’m still an hour off but there’s a patch coming this weekend or early next week to fix that. The error message “Admin Login Failed” is now gone. I took off the battery cover and pressed the reset button 10 seconds. Then removed the device using my phone app and then added it back in. Had to reset everyone’s login number and fingerprints (thankfully we don’t have many employees) and now it works! Only took Utec a week and a half to help me fix it.

Logs are always wrong during daylight saving?
You’d think it would work off system time.
Daylight savings ending here in Australia soon.
Looking forward to the log times being accurate for the next 6 months :joy: