Latch 5 Fingerprint Stuck on Lock Update

I’m trying to update the lock to Version:01.28.0016 and it’s stuck on 10%.

The Bluetooth firmware update worked but the lock firmware is stuck. It’s been 10 minutes and it’s my second attempt.

Also instead of “Break Off” that should probably say “Cancel”.

Not sure if this got lost over the holidays. Bumping this.

Cc @Carrie

I have also made this update more than once. Somehow it goes back to the previous version even though the update said success.

Hi, you should make your lock configured wifi first. Once this is done, it should be updated automatically. If not, please tell me and I will help.

1 Like

I got the update to succeed but now I can’t get the keypad to pop-up.

I can unlock with my fingerprint but double tapping the keypad or any taps for that matter don’t get the keypad to pop-up anymore.

You need to touch the keypad with more than two fingers. This way it could prevent random lighting up the screen to prolong the battery life.

That worked thank you.

Now can we get a home assistant integration for Bluetooth locks, or an API and the community can get the integration setup also, more attributes for the Z-Wave locks to read/write? :slight_smile: