False Low Battery Alert - Batteries Are Still Good

Seems like there are many threads on this, so sorry if this has actually been answered, but after enough troubleshooting, I have determined that my batteries are falsely detecting as low battery after about 4 weeks. I have the original Ultraloq batteries that were supplied with the lock, along with a set of Duracell PowerBoost (Alkaline) and Energizer Max (Alkaline). All 3 sets detect as low battery after about 3-4 weeks. If I ignore the warning, they eventually detect as dead and the lock stops working. But when I put them on a battery tester, they still tested as good. I swap the “dead” batteries out with any of the others, and the same thing happens in 3-4 weeks. If I put the “dead” batteries back in, they detect as High and work for another 3-4 weeks before I have to repeat the process. So, to me, this clearly seems like a firmware issue that is falsely detecting these batteries are dead. Especially because I am now on my 3rd round of the original Ultraloq batteries and they are still reporting as High even though they have been “dead” twice. Anyone else coming to the same conclusion? Even better question…anyone have a solution?

Ultraloq Pro Wifi
Lock Firmware: 01.38.0023
Bluetooth Firmware: 00.05.0050

TIA,
Mike

Holy smokes! I’ve been throwing away batteries every month and have really been disappointed in the battery life. I then switched to rechargeable batteries but they had a different diameter causes connection issues. So now I’m back to tossing batteries every month on this lock. I’ll try cycling between two sets now and see what happens.

@Mike1 We are so sorry for this inconvenience caused for you. Please make sure the wifi connection is good and then please update the lock firmware to the latest V1.40. Will this help to resolve the issue? If still not, please click here to submit a ticket so that we can further support you.

@david42 Please try to update the lock firmware to V1.40, will this help to improve the battery life for your lock? If the issue remains, please click here to submit a ticket so that we can further support you.