NEW U-BOLT WIFI BETA/ New Beta version of the App is available to fix the firmware update issue✳

Updated U-tec app to v 1.11.8 (108).

Tried the firmware update to V01.22.0023
–verified wireless was connected
–ran the firmware update
–ran for about 6m4s and failed with “Failed to update firmware. Please try again.”

Will try try it again closer to the lock and do a factory reset if that doesn’t work.


I repaced the batteries for the 2nd time in 2 weeks . Couldnt do the firmware update. So i deleted it. After multiple tries at scanning it finally showed up. It wouldnt connect to the internet. Deleted it again and did a hard reset. Can’t get it to show up to add. Using an IPad pro and a Samsung s22+ phone. The auto lock works for about a day then stops working.

Downloaded new app



Downloaded new app version and was able to update the firmware. Immediately the battery showed alert and it had previously showed high. Was able to add sensor and after several tries was able to get auto lock set to 1 minute. Still very buggy

I just got 1.11.8 version pushed to my device. The firmware was previously updated and all seems to be working as expected so far. I have not had battery issues like others.

I’ve updated to the following.

  1. Lock Firmware - v01.22.0023
  2. WiFi Firmware - v00.04.0050

Update took tries (6x) over a 3-4 hour period the other night. Same symptoms regarding the WiFi signal strength being strong but still not found. Seems to be pseudo-random whether it gets a signal and is able to communicate.

I also encountered a transient bug. The lock would autolock immendiately after it was opened. I acutually had to pull the batteries out just to open the door. This problem seems to be resolved by the latest update.

One feature my spouse noted is missing from the previous model: the lighted buttons.