Auto Unlock No Longer Works After Latest App Update

@Frank any update on when that app update for Android is releasing?

Received the app update on my s22 this morning (1/19) and auto lock is now working. My wife received the update on her s20 2 days ago and auto lock started working.

… 4 attempts later. Finally got it to work. I’ve spent too long with it today so hopefully it will work on my next trip out.

In the end I had to: remove the device (lock) from the app, delete the app, reset the lock (pin on the bottom), reboot the phone, download the app, install the app, setup the lock, reset the distance to 1000, place the lock on the map 15 ft-ish in front of my front door. Then I had to go into the app permission settings and make sure it activated the precision location, run all the time, allow run in the background, auto run, and all the other damn settings. Then on my 4th attempt it finally worked. . But… It’s auto locking twice! With only having one verified unlock out of 4 attempts.

With the app updated on my iphone, the Auto Unlock has worked 3 times out of 3 times that I left the house and returned in the last 2 days. Definitely better already than it has been in the last couple of months since the app V2 update, so for anyone still having issues I definitely recommend getting the app that was just updated to v2.0.8 and then making sure that your auto lock settings are on, your lock location is properly set, and that the app has “always” permissions and precise location enabled.

Seems like it’s v2.0.8 for iOS and v2 0.9 for Android.

Received app update on 1/19 on S22 and auto lock worked perfectly for 1 day. For the last 2 days there’s a 5 minute delay when leaving / coming home so it’s pretty much worthless again. Pretty damn frustrating.

So after the app update Auto Unlock worked well for me for like 3 days, but it hasn’t worked at all since then for like 5 more days now. Around the same time it stopped working for me, I had also re-enabled Auto Unlock on my wife’s phone (since I was convinced it was working well at the time) and it hasn’t been working for either of us now. Not sure if that might have something to do with it or not but I will be testing this theory by disabling it on her phone. This is the standout feature that made my buy this deadbolt and it’s really annoying that ist has worked well enough for several years now but since the v2 app update it’s been almost entirely non functional

Same issue. iPhone 13 Pro. V2.08 app. Latest firmware.

Another week has gone by and I haven’t had a single auto unlock work. The app also seems a lot slower to connect to my locks recently. Seems like utec is really struggling to keep their products working well, and it’s disappointing that they have gone radio silent on a lot of these posts. Would love to hear that they have at least recognized that the latest app update has not fixed auto-unlock. Let us know that you are working on a fix for this, please.